tis-dotnetfx4.6 4.6.2-8

  • package : tis-dotnetfx4.6
  • version : 4.6.2-8
  • description : dot net FX 4.6.2 Framework CLient. replace 4/4.5/4.5.1/4.5.2/4.6/4.6.1
  • maintainer : TIS <technique@tranquil-it-systems.fr>
  • date : 2017-11-07 13:43:07
  • signer : TRANQUIL IT SYSTEMS
  • signature_date : 20171107-134306
  • min_os_version :
  • min_wapt_version :

setup.py

from setuphelpers import *
import platform

uninstallkey=[]

def install():
    if windows_version() >= WindowsVersions.Windows10:
        dot_net_release = 394802
    else:
        dot_net_release = 394806
    actual_release = registry_readstring(HKEY_LOCAL_MACHINE,'SOFTWARE/Microsoft/NET Framework Setup/NDP/v4/Full','Release')
    if not actual_release: actual_release = 0
    print("installing Dot Net fx 4.6.2 - Release %s" % dot_net_release)
    if platform.win32_ver()[1] <> 'XP':
        if actual_release < dot_net_release:
            run("NDP462-KB3151800-x86-x64-AllOS-ENU.exe /q /norestart",accept_returncodes=[0,3010])
            installed_release = registry_readstring(HKEY_LOCAL_MACHINE,'SOFTWARE/Microsoft/NET Framework Setup/NDP/v4/Full','Release')
            if  installed_release < dot_net_release:
                error('Microsoft .NET Framework 4.6.2 not found after install')
            print("After install, restarting your computer is recommended.")
        else:
            print('Already there or superior - Installed release is : %s' % actual_release)
    else:
        print("dotnet fx4.6.2 is not available for Windows XP")

    ## Documentation :
    ## DotNet product version numbering : https://docs.microsoft.com/en-us/dotnet/framework/migration-guide/how-to-determine-which-versions-are-installed

    

manifest

Couldn't retrieve manifest.
    

Forum feed

WAPT Packages / Paquets WAPT • Re: dotnetfx4.7 ne fonctionne pas
Bonjour,

DotNetFX 4.7 n'est plus un redistributable comme les précédentes version mais une KB désormais c'est pourquoi il n'apparait pas dans "Ajouts/Suppressions de Programmes" (appwiz.cpl)

Pour observer la version installée :

CODE :

Get-ChildItem "HKLM:SOFTWARE\Microsoft\NET Framework Setup\NDP\v4\Full\" | Get-ItemPropertyValue -Name Release | ForEach-Object { $_ -ge 394802 } 
https://docs.microsoft.com/en-us/dotnet ... alled#ps_a

Statistiques: Posté par agauvrit — 12 janvier 2018, 11:34


WAPT Packages / Paquets WAPT • dotnetfx4.7 ne fonctionne pas
Bonjour,

J'essai d'installer le paquet "dotnetfx4.7", il s'installe très bien (ce que la console me dit) mais sur ma machine distante il n'y a aucune erreur mais le framework n'est pas installé dans mes programmes.

Merci

Bonne journée

Statistiques: Posté par Killian — 09 janvier 2018, 14:32